UNIT 1. APPLICATION AND UTILITY SOFTWARE INSTALLATION
1.1. Operating system (OS)
Operating system: Is a large and powerful program that controls and manages computer hardware and software. 
Desktop Operating System (DOS): Is an operating system that runs a laptop or desktop computer.
This includes:
· Microsoft windows (Windows 10, Windows 8)
· Mac OS
· Chrome OS
· Linux (Ubuntu, Fedora)
Mobile Operating System: Is an operating system that runs smart phones, PDAS, Tablet PCs and other mobile devices.
This includes:
· Android
· iOS
Server Operating System or Server OS: Is an operating system that is installed and runs on servers.
This includes:
· Windows server
· Linux
· Free BSD 
1.2.  Function of operating system
Computer hardware
User
Application software
Operating system


1. Booting: OS is responsible for completing booting process of the computer.
Booting: Is starting or restarting the computer.
· Cold boot: Starts the computer that has been turned off completely.
· Warm boot: Restarts the computer’s operating system.
2. The OS provides an appropriate user interface.
3. OS manages resource allocation to various programs.
4. Memory management.
5. Manages user’s files.
Note: File system: A method used by the OS to name, store and organize files on a disk.
6. OS controls input / output peripherals.
7. OS manages files.
8. OS manages backup storage (secondary storage or auxiliary storage).
9. OS manages security and access rights of computer users.
10. OS handles errors as they happen.
1.3. Types of license for software
A software license: It defines the rights of the software producer and that of the end user.
Two types of license for software:
· Open source software
· Proprietary software
a. Open source license (General Public License or GPL): It is a license that allows the software to be freely used, modified and shared.
b. Proprietary license: It is owned by an individual or company that developed it.
1.4.  Download software
Downloading: Is a transfer / copy of a software through the internet from the server to a local machine or computer.
Downloads: The computer’s default download location.
Steps:
· Open your Browser
· Use the search engine and type Download Google Chrome
· Press Enter key on your keyboard
· Click the search result you think is best for you.
· Click the Download chrome button.
· Open your downloaded file(s)
1.5.  Installation of software
Installation of software: It means of putting a computer program on a computer and ready for use.
System requirements for installing software
· Processor speed (The higher the speed the better)
· RAM size
· Hard disk space
· Graphics card
1.5.1. Installation of operating system
OS is installed in a separate section of hard disk referred to as disk partition.
Disk partitioning: Is dividing hard disk into partitions.
Steps:
· Backup all your data on an external storage device.
· Start your computer and then connect the bootable USB flash drive or insert the bootable windows 10 DVD on the PC where you want to install windows 10.
· Restart your PC, and then Press any key to boot from the USB flash drive or the DVD. Select your language, time, keyboard preferences and the click on Next.
· Click on Install Now.
· To provide a 25-character product key, then click Next. (You can click on Skip if you don’t have a product key).
· Click “I accept the License terms”, after click Next.
1.5.2. Install Microsoft office 2016 on selected computer (s)
To install application software success fully you must use an Administrator account.
Product key: Is a specific software based key for a computer program and certifies that the copy of the program is original.
Steps:
· Open Ms office installation DVD
· Insert the Disc in the optical drive (DVD drive)
· Open an Office application (Example: Word 2016)
· Click Close after installation
· Click “I want to activate the software over the internet” and then follow prompts.
1.5.3. How to install application software (installing skype)?
· Obtain a Disc that contains the software to be installed. (or folder if it was downloaded)
· Insert the Disc in the disk drive.
· Open the Disc. Open the folder containing installation.
· Double click on the setup file for skype to install.
1.5.4. Install antivirus
Antivirus: An utility program used for scanning computer viruses and removing them from the computer.
Examples:
· Norton
· Kaspersky
· AVG
· McAfee
· Avast 
Similar steps are used to download and install different antiviruses.
Uninstall application software
· Right click the Start button and select Control panel.
· Select Uninstall a program.
· In the programs and features screen, select the Program you want to uninstall.
· Wait for the Windows installer.
1.6. Software add on
Software add on: Is a piece of software that adds a specific feature or capability to an existing software application
Examples:
· Adobe flash
· Quick time
· Silver light
Role of add on
· Interface change
· Adding features
a. Interface change: The application can be dynamically to have friendly interface suitable for different users.
b. Adding features: More features are added to the browser (program) to increase its usability.
Download and install add on
· Go to the Mozilla home page.
· Click Add on
· Go to the Add on or extension you want to add.
· Click the Add on you want to download.
Download helper: A tool used to extract videos and image files from websites and save them to your hard drive.
· In the new tab for Add on manager, click in the search box at the upper right hand corner of the window.
· Type in the word YouTube and press Enter key.
· Click the Install button next to the result “1-click YouTube video download”.
· Once the installation is complete, wait for a few seconds and then restart Firefox.
· Type in the Address bar www.YouTube.com. Locate your favorite video and click on it.
· If “I click YouTube video download” is used, to download a video on YouTube, there is a red button under Active Video download.
· Form Save as dialog box, select location to save your video and click Save continue to download the page.
Watch the downloaded video at any time you want, using location specified.
Ad blocker: Is software extension that reduces the number of unwanted, uncalled for pop up ads which appear on the user’s display in a browser.
Example: Ad bloc plus
Ad: Is a short for Advertisement.
Why should you remove ads?
Many reasons are:
· People do not want to be manipulated by online advertising.
· Advertising is an noying in most cases.
· Advertising often uses heavy graphics which slows the page loading.
· Online advertising imposes a security risk for the internet user.
How to disable remove browser Plup-ins and add on
For Mozilla Fire fox
In the menu bar select Tools > Add on or click the Open menu button and select Add on.
· In the Add on manager screen, find the Add on from the list of currently loaded Add ons on the right.
· Select it and click on the Disable button at the bottom right.
Windows users may also able to uninstall add on files through the Control panel.














UNIT 2. TABLE OF CONTENTS AND MAIL MERGE
2.1. Table of contents (TOT)
A table of contents: A piece of information used by readers to quickly find or locate what they are looking for in a book, magazine or any piece of literature.
Creating table of contents
a. Start Ms word and then create a new document in which you need to add table of contents. Then type the text to be used.
b. Apply heading styles to the text that you want to include on the table of contents.
Procedure to apply heading styles
· Select text you want to be included in table of contents.
· Choose one from the following heading from Home tab in the Styles group.
c. Generate an automatic Table of contents for the document at the beginning of your document.
d. Click where you want to insert the table of contents.
e. Click References > Table of contents, and then choose Automatic table 1 style from the list.
Update table of contents
If you add or remove some headings or information from the document, you can update quickly using the following procedure.
1. On the References tab, in the Table of contents group, click Update table.
Or
2. Select Update entire table. Then click Ok.
Delete table of contents
· On the references tab, in the table of contents group, click Table of contents.
· From the table of contents menu click Remove table of contents.
Customize table of contents
· On the Table of contents menu, select Custom table of contents.
· Select the tab leader you need, number of levels and other options.
· Click on Ok to save changes you need in the document.
2.2. List of tables and list of figures
List of tables and list of figures: Is used to keep information organized and provide easy access to a specific element needed in the document.
a. Creating a list of tables
1. Add captions to every table in the document using procedure given below:
· Select a table on to which you need a caption.
· Click Insert caption command on Reference tab.
· Edit table caption and click Ok.
2. Click where you want to insert the table of figures.
3. On References tab in the Captions group, click on Insert table of figures to build the table.
4. Select the caption label as Table and click Ok.
5. Adjust table’s formatting such as setting whether to show page number or changing the style of tab leader.
6. Click Options in the table of figures dialog box. Check Style and select style used for your figure labels.
b. Creating a list of figures
· Repeat step 1 in (a) above (Creating a list of tables)
· Repeat step (2) of part (a) (Creating a list of tables)
· Repeat step 3, however in table of figures dialog box, select Figure.
· Click Ok.
2.3.  Mail merge
A mail merge: The process that produces personalized letters by combining a database of names and addresses with a formal letter created in a word processor.
Creating a mail merge document
· Create a letter which you will send to various persons.
· On the Mailings tab, click the Start mail merge button and then select Letters in the menu.
· Click on the Select recipients button which is next and in the list that appears select Type a New list.
· Click Customize columns.
· Click Ok. Then start entering in your data.
· Click Ok.
· The Save address list box will display. Type in the file name, then save it.
· Click on Edit recipients list on the Mailings tab, in case you want to edit some recipients. (This step can be ignored)
· a. Click a location in the main document (Letter) where you want to insert the first merge field.
b. Click on the Insert merge field button, then choose appropriate one.
c. Repeat the above step until all field in the data file are inserted in the document. (Letter)
d. Preview results using the Preview results group button.
· a. Click on Finish & Merge button in the Finish group; select Send email messages to send merged documents as Emails.
Select Print documents to send merged documents directly to the Printer to be printed.
Or
Select Edit individual documents to edit and print copies after merging then.
b. Select Edit individual documents, the Merge to new document dialog box will display. Select All and click Ok.
c. Save the document using a new name or location.
d. Print your document when you need.
2.4.  Organize, print and view shortcuts
Before you print your document, you should preview your document and specify which pages you want to print.
Steps to preview your document
· On the File menu / tab click Print.
· To preview each page, click the Forward and backward.
· Use the Zoom slider to enlarge a page.
· Enter the number of Copies, to print.
· Select a Printer to use under Printer.
· Under Settings, select options you need.
· Click on Print button to produce a hardcopy of the document.
2.5. Protect your document
There are 2 methods to protect a document with Password.
Method 1
· Create or open an existing document a document. Click the File tab.
· Click Info
· Click Protect document
· Click Encrypt with password
· Type the desired password for your document.
· Retype the password again to confirm it and click Ok.
Method 2
· Create or open an existing document
· Click File tab, click Save as
· Click Browse as save location
· Click Tools
· Click General options
· Types in password to open the document. retype the password and click Ok.









UNIT 3: CHARTS AND ADVANCED OBJECTS
3.1. Charts
A chart: Is a diagram or object used to display numerical information in details. It can also be a graph.
3.1.1. Role of charts
· They are used to summarize and display information I an easy manner to understand.
· Charts act as useful tools for conveying financial information. They are used to make patterns and trends in numerical order much easier to see.
· Charts facilitate data analysis.
3.1.2. Types of charts
The most popular types:
· Bar chart (Bar graph)
· Column chart
· Line chart (Line graph)
· Pie chart
a. Bar chart: A graphic representation of data with horizontal bars or objects.
b. Column chart: A graphic representation of data with vertical bars or objects.
c. Line chart (Line graph): A graphic representation of data plotted using a series of lines.
d. Pie chart: A circular chart sliced into sections; each section represents a percentage of the whole.
3.2. To create a chart or graph
· Prepare the data that you need to make the chart.
· Start Microsoft word and then click where you want to place the chart.
· On the Insert tab, in the Illustrations group click Chart.
· In the Insert chart dialog box, select the type of chart that you want on the left side, then select the chart sub type and finally click Ok.
· The chart remains selected a chart tools display (Design, Layout, and Format tabs). Use chart tool to modify your chart the way you want.
· Replace the sample data by clicking on a cell and then typing the data you want.
3.3. Formatting an object and chart
· Select a chart you want to format.
· Click Format tab under Chart tools and select a formatting button you want.
For example:
· To apply word Art styles on chart 
· Adjust chart size
3.4.  Add object from file
On the Insert tab, click Object command from the Text group.
3.5. To add object from Microsoft Excel to another type of document
· Create a new document or open an existing document.
· Click where you want to insert the object.
· On the Insert tab in the Text group, click Object button.
· In the Object type list, scroll and select the type of object you want.

UNIT 4: CHARTS AND OBJECTS IN SPREADSHEETS
4.1. Charts (Graphs)
A chart: Is a graphical representation of numerical data. It is a sheet of information in form of a table, graph, diagram or object.
Charts enable users to see results of data in detail, interpret and predict current and future data in a much easier way.
4.1.1. Uses of charts
· Used to summarize numerical information.
· View relationships between different variables. Example: Price against sales volume.
· Detect trends overtime and make forecasts.
· Search for patterns among a large amount of figures.
4.1.2. Types of charts
1. Column chart
It displays data as vertical bars.
2. Bar chart
It represents data mainly as horizontal bars or object.
Difference between column and bar charts
A bar chart represents data using horizontal objects but a column chart uses vertical objects.
Similarity between column and bar chart
Both bar and column charts represent data using bars or columns to compare items. The length of each bar or column is proportional to the data that it represents.
3. Line chart (Line graph)
It is a graph representation of data plotted using a series of lines.
4. Pie chart
It is a circular charts sliced into sections, each section represents a percentage of the whole.
5. Scatter chart / graph
It is a graph of plotted points showing the relationship between two sets of data.
A scatter (XY) plot: Is a graph used to plot the data points for two variables.  Each scatter plot has a Horizontal axis (X-axis) and a Vertical axis (Y-axis).
4.2. To create a chart in Ms Excel
· Create or open an existing workbook with well-prepared numerical data.
· Select all the cell data you need to be represented in the chart (Including all the labels and titles)
· Click the Insert tab, in the Charts group, click on the chart type you want, and then click on the subtype.
· The new chart displays automatically as Floating object. 
If you want the chart to be on a separate sheet do the following:
· On the Design tab, under Chart tools, in the Location group at the right, click on the Move chart.
· In the Move chart dialog box that displays, choose where you want the chart to be placed and click Ok.
· The new chart will display on its page.
4.2.1. How to apply a predefined chart layout to your chart?
· Select the chart / graph
· On Design tab, in the Chart layouts group, click Quick layouts button. Select layout you want.
· Replace the default text in the X-axis, Y-axis titles and Chart title with your text.
4.2.2. How to apply a predefined chart style?
A style: Is a format clearly created which you can use to improve appearance of your chart.
· Click in the Chart that you want to apply a style.
· On the Design tab, in the Chart styles group, click the chart style you want to use.
4.2.3. Creating a combination chart
A combination chart: Contains data series plotted using more than one type of chart.
· Create a chart containing all the data you want.
· Right click on the data series you want in the chart.
· Select the Change series chart type from shortcut menu.
· Select a different chart type and then observe the changes.
4.2.4. Change chart type
· Select the chart you want to change.
· On the Design tab, in the Type group, click Change chart type.
· In the Change chart type dialog box that displays, select the Chart type and Subtype you want.
· Click Ok.
4.3. Formatting chart
To format a chart: Is to change the appearance of a chart so as it looks attractive.
· Create or open an existing chart in Ms Excel.
· Select any part of the chart.
· On Format tab, in the Current selection group, click Format selection. You can use right clicking for formatting chart.
4.4. Format cell data as a table
Cell data: Is any piece of data you want to format as a table contained within spreadsheet cells.
· Select the spreadsheet data you want to format as table or click in it.
· On the Home tab, in the styles group, click Format as table drop down list and select a desired table style from the list.
· Format as table dialog box appears, click Ok.
· Table tools display on the Design tab. Use table tools to modify your table as desired.
4.5. Printable datasheet
Before you print a worksheet, it is important that you set a print area.
Printing: The action of producing a hardcopy information using a printing machine such as a Printer or Printing press.
Page setup options control the layout of a printed sheet and therefore must be used before a worksheet is printed.
Page setup options:
· Margins
· Headers
· Footers
4.5.1. To set page margins
· On the Page layout tab, in the Page setup group, click Margins and in the menu select Custom margins.
· In the Page setup dialog box for margins, increase or reduce the margins and click Ok.
4.5.2. Set headers and footers
A header: Is information printed at the top of every page.
A footer: Is information printed at the button of every page.
Headers are suitable for company names, page titles; footers are good for page numbers and printout dates or times.
You can insert header / footer by clicking on Insert tab, in the Text group, click Header / Footer. Automatically the cursor goes in the center of the header.
Insert header / footer (For chart sheet)
· On the Page layout tab, in the Page setup group, click Dialog box Launcher.
· In the Page setup dialog box that displays, click on Header / Footer tab.
· Click on Custom header to insert your header or Custom footer to insert footer.
· Click in the Left section, Center section, or Right section box, and then click the buttons to insert the header or footer information that you want in the section.
4.5.3. Print area
Print area: Is one or more ranges of cells that you designate to print when you don’t want to print entire worksheet.
A worksheet can have multiple print areas. Each print area will print as a separate page.
To define or specify the print area
· Create or open an existing worksheet.
· Select the cells you want, define as Print area (Data range)
· On the Page layout tab, in the Page setup group, click Print area, and then click Set print area.
Note: A line around the data marks the print area. When you save a worksheet the print area is also saved. Use the same steps given above to add and clear the print area.
4.5.4. Printing a chart
If you want to quickly print the chart which is part of the data:
· Select / click the chart and press CTRL + P on keyboard.
· Click Print button to print using default printer.
If the chart is on a separate sheet:
· Select Print on the File tab, or Ms office button, then click Print button to print from default printer.






UNIT 5: PRESENTATION
5.1.  Presentation
A presentation: Is an organized report or message prepared as a talk before audience with the help of a computer program.
Examples of programs / software which you can use to create presentations
· Ms Power point
· Harvard graphics
· Corel presentations
· Open office.org impress
· Lotus freelance graphics
· King soft presentations
Presentation software: Is a program used to create slide shows for presentation on screen to an audience.
They can supplement or at times can replace use of visual aids like:
· Handouts
· Chalkboards
· Posters, …
5.1.1. Role of presentation applications
· Conveying information about an important issue such as disease control measures.
· Introducing a new idea for business.
· Reporting progress using chart or graphs.
· Training by demonstrating how it is done.
5.1.2. Working with Ms Power point presentation
Ms Power point: Is presentation graphics software commonly used when you plan to give a talk as a presentation.
Power point presentations can be done on the computer screen if the audience is very small. If the audience is large the computer can be connected to a projector that projects the image onto a large screen / wall.
5.1.3. Launching Ms Power point presentation
· Click Start button and select All apps.
· Scroll down and select Power point 2016 (or click Ms office and then select Ms Power point)
· The Presentation gallery displays. Select the Blank presentation with a new slide to begin from scratch.
5.1.4. Saving a presentation
When you open Ms Power point by default you have created a presentation.
· On the File tab, click Save as to get the backstage view for save as.
· Select a location or Browse a location to save your file.
· In the Save as dialog box, type in the desired File name and then click Save.
Note: 
· Access quickly the Save as backstage view by pressing CTRL + S on keyboard or clicking Save button on the Quick access tool bar.
· By default, power point 2016 save files in the power point presentation (.pptx) file format. To save in another file format, click on Save as type list and select the file format you want.
5.1.5. Opening an existing presentation
· Start Ms Power point program.
· On the File tab, click Open.
· Select a location where your file is located or Browse in folder to find the file. In the open dialog box, in the File name box, type the name of the file you want to open (or scroll, locate and double click on the file).
· Click Open button and the file will open.
Note: After starting power point, you can quickly access the Open backstage view by pressing CTRL + O on the keyboard.
Other methods for opening an existing presentation
· Click Start button
· In the Search box, type the file name and press Enter key on keyboard.
5.2. Components of presentation environment
· Maximize button (Makes window fill the whole screen)
· Close button (Closes the presentation)
· Save button
· Quick access tool bars
· Slide pane
· Slide title
· Body content
· Vertical scroll bar
· View buttons
· Notes pane
· Slide navigation pane
5.3. Slides
A slide: Is a single page of information in a presentation created with programs such as power point or Corel presentation.
A presentation is made up of several slides.
5.3.1. Insert a new slide
After working on the first slide, you need more slides to complete your presentation. On Home tab, click New slide button. (Or just press CTRL +M on keyboard)
5.3.2. To cut or copy and then paste slides
· In the Slide navigation pane, click on the slide you want to cut or copy.
· On the Home tab, in the Clipboard group, click Cut or Copy button.
· Click in the destination place and then on the Home tab, in the Clipboard group, click Paste button.
5.3.3. Apply design theme in a presentation
· Click on the Design tab.
· From the Themes group select theme you want.
· Select a Theme variant in case you need it and then save changes to your presentation.
5.4. Objects
An object: Is something that you can see or touch. There are several objects that you can insert in presentation software.
These include:
· Text box
· Images
· Table
· Clip Art
· Word Art
· Smart Art
· Shapes
· Charts
· Media clips
5.4.1. Text box
Text box: Is a box in the program from where the user can type or edit text, dates or numbers.
There is a difference between Text placeholder and Text box. You cannot inset a Text place holder in a slide since it is part of the layout for your slide and exists when you insert a new slide but Text box need to be inserted manually.
5.4.2: Images
An image: Is the actual picture or mental picture of something. Adding pictures can make your presentation more interesting and attractive.
· Select the Insert tab, then click the Pictures command in the Images group.
· Insert picture dialog box will appear. Locate from your PC and select a desired image file, then click Insert.
· The picture will display on the currently selected slide.
Note: You can also click the Pictures command in the slide Place holder to insert images (for new slide).
5.4.3. Inserting online pictures (Clip Art)
In case you don’t have a desired picture on your computer, you can find a suitable Picture online and then add it to your presentation.
In Power point 2016, online pictures are used instead of Clip Art that exist in earlier versions of the program.
· Insert a new slide after the last slide.
· On the Insert tab, in the Images group, click Online pictures command.
· The Insert pictures dialog box will appear.
· Choose Bing image search.
· Press Enter key. Your search results will appear in the dialog box.
· Select the desired image, then click Insert.
· The image will appear on the currently selected slide.
Note: You can select Online pictures command in a Place holder to insert online images.
5.4.3.1. Moving and resizing pictures / images
Once a picture is inserted, it may require you to move it in a different location on the slide or change its size.
5.4.3.2. To move a picture
Click and drag to move picture to a new location you want on a slide.
5.4.3.3. To delete a picture
Select the picture and then press Backspace or delete key on your keyboard.
5.4.3.4. Resizing picture
· Click on the picture. The picture will display selection circles.
· On the Format tab, click on Shape height and or Shape width using existing arrows.
5.4.4. Table
A table: Is made of rows and columns. Data or information can be arranged using these rows and columns.
Methods
· Create and format a table within a presentation.
· Import a table from word or a group of cells from Excel spreadsheet.
5.4.4.1. Method 1: Create and format a table in Ms Power point
· Select the slide that you want to add a table to. In this case add a new slide after last slide.
· On the Insert tab, select Table.
· In the Insert table dialog box displays.
Note: Either use a mouse to select the number of rows and columns you want or select Insert table and enter the number in Number of columns field and Number of rows field. Lastly Ok.
· To add text to the table cells, click a cell and then enter your text. After wards click outside the table.
5.4.4.2.  Method 2: Copy table
· Open a word document containing a table you want to copy.
· On the Layout tab (Table tools) in the Table group, click Select and then click on Select table.
· On the Home tab in the Clipboard group, select Copy.
· Click on your Power point presentation, select a slide where you want to copy the table to. On Home tab, in the Clipboard group, click on Paste.
5.4.5. Word Art
Word Art: Is an object that you can move, resize or rotate within the document.
· Select the slide where you want to insert a word Art.
· Click on the Insert tab and then click on the Word Art button in the Text group.
· Select on the Insert a Word Art style you want to use. The Word Art textbox will be inserted on the slide.
· Move the Word Art in suitable location and then delete the original text and text box.
· Repeat steps 1-4 and apply a desired word Art to all slide titles.
· Click on the Word Art box and then type the desired text.
5.4.6. Smart Art
Smart Art: Is a picture used to communicate information in many different ways. It is an option that allows the user to create diagrams easily.
Create a smart Art graphic and add text to it
· You open an existing presentation or create a new presentation.
· On the Insert tab, in the Illustrations group, click Smart Art.
· In the Choose a smart graphic dialog box that displays, click the type and layout that you want.
· Enter your text by either. Clicking in the text pane (left) and then type your text or clicking directly in the Smart graphic and type the desired text.
5.4.7. Shapes
A shape: Is an outline form of an object.
· Click on insert tab.
· Click Shapes from the Illustrations group.
· Select a shape and then click and drag to draw the shape in the desired place.
After drawing a shape, you can add text, bullets and numbering to them. You can also change their fill, outline and other effects on the Format tab.
5.4.8: A chart
· Insert a new slide
· Click the Chart button in the content holder to generate a column chart.
Alternatively use chart appears together with a data sheet that you should edit to suit your chart.
· The column chart appears together with a data sheet that you should edit to suit your chart.
· Edit data sheet by replacing default data with your data.
5.4.8. Media clips
Media clip: Is a small segment of an electronic media either an audio clip or a video clip.
5.4.9.1. Audio clip
· In Normal view, select the slide where you want to insert an audio clip.
· On the Insert tab, in the Media group, click arrow under Audio, and then click Audio on My PC.
· In the Insert Audio dialog box, select a folder with the audio you want and then select the file.
· Click on Insert button to insert the audio.
· The slide where audio has been inserted will have a graphic. Play using the Media buttons displayed.
5.4.9.2. Video clip
There are 2 ways to insert video:
· Embedded videos
· Linked videos
a. Embedded videos: Are appropriate but tend to increase the size of your presentation.
· In Normal view, select the slide where you want to insert video clip.
· On the Insert tab, in the Media group, click arrow under Video, and then click Video on My PC.
· In the Insert video box, click the video that you want from a specific folder.
· Click Insert.
b. Linked videos: Keep your presentation smaller in size because links can easily break, copy the video into the same folder as your presentation and create the link from there.
· Follow steps 1 to 2 above (For embedding video clip)
· In the Insert video dialog box, click the file that you want to link to.
· Click the down arrow next to the Insert button, and then click Link to file.
5.5. Formatting a slide
To format a slide: Is to change the appearance of the slide and or its contents.
· Select text to apply a font. Font changes size, color, style, shadow, from the Home tab. Apply them to all slides.
· Change Background, click Format background on the Design tab.
· Change Slide layout.
5.6. Animation of a presentation
· Animation
· Transition
a. Animations: Are presentation features that give motion or life to text or object in the slide show.
· Select text or object you want to animate.
· On the Animations tab, in the Animations group, select one animation you want.
· Apply Timing to animation, that is, in the Timing group, increase or reduce the duration or delay of the animation.
b. Transition
· Click on the Transitions tab.
· Select a transition effect of your choice from the Transition to this slide group.
· Click Apply to All in the timing group so that the transition selected is used by all the slides.
· Click Preview in preview group to see how the selected transition works.
· Save the changes to your file by pressing CTRL + S on keyboard.
5.7. Presentation view
On view tab in the Presentation views group, click a Presentation view that you want.
The views used for creating and editing a presentation 
· Normal view
· Slide sorter view
· Notes page view
· Reading view
· Master view
a. Normal view: It is the main working window in the presentation. Every slide is show full size on the screen.
b. Slide sorter view: This a window that displays miniature (small) versions of all your slides, arranged in horizontal rows. This view is very useful when you want to duplicate, delete, hide or reorder.
c. Notes page view: This is located under slide pane. It shows a smaller version of a slide with an area below for adding speaker’s notes page. The notes do not show on the screen during the presentation.
d. Reading view: In this view a slide is shown in full screen mode like it is to slide show view.
e. Master view: Are main slides that store information about the presentation including:

· Background
· Color
· Fonts
· Effects
· Place holder sizes
· Positions
These views include:
1. Slide master: When you make a change on the slide master, it replicates on all the slide layouts and slides.
It is important to make modifications to your slide master and slide layouts before adding slides to your presentations. This makes items on the slides to conform to slide master design.
2. Handout master: A handout master is a document that you can print from within a power point presentation.
To access handout master
· Click View tab on the Ribbon
· Select Handout master from Master views group.
3. Notes master: Each slide in your presentation could have notes associated with it and these placed in the Notes pane area. If you want to modify and print these notes, you make use of the Notes master.
To access Note master
· On the View tab, click Notes master in the Master views.
Slide show
Slide show: Is a window that fills the whole screen when it runs. It displays any animations or transitions added to the slide in the presentation.
Each page of a power point presentation is called a slide and the default orientation of the slide is in Landscape layout.
UNIT 6: INTRODUCTION TO COMPUTER GRAPHICS
6.1.  INTRODUCTION
Changing what you draw can be easy or hard: you can erase pencil or charcoal marks easily enough, and you can scrape off oil paints and redo them with no trouble, but altering water colors or permanent markers, swapping color or resizing your picture is more complicated.
6.2. Definition
1. Computer graphics
It is the use of a computer and specialized programs to produce and manipulate pictorial images.
Purpose of creating computer graphics
· Animation
· Business presentation
· Scientific research
2 ways of drawing digital images on a computer screen
· Raster
· Vector
2. Bitmap / Raster graphics
It is a digital image composed of a matrix of dots. It is composed of many tiny parts, called Pixels which are often many different colors.
When you take a photograph using a digital camera or scan an image from a magazine, you are creating a bitmap graphic.
3. Vector graphics
They are mathematical calculations form one point to another that form lines and shapes.
4. Comparing graphics and vector graphics
	Vector graphics
	Raster (Bitmap) graphics

	Mathematical calculations that form shapes.
	Pixel – based

	Vector programs best for creating logos, drawings and illustrations, technical drawings. For images that will be applied to physical products.
	Raster programs photos and creating continuous tone images with soft color blends.


	Can be scaled to any size without losing quality.
	Do not scale up optimally. Image must be created / scanned at the desired usage size or larger.

	A large dimension vector graphic maintains a small file size.
	It is more difficult to print raster images using a limited amount of spot colors.

	Number of color can be easily increased or reduced to adjust printing budget.
	Some processes cannot use raster formats.

	Vector art can be used for may processes and easily rasterized to be used for all processes.

	Depending  on the complexity of the image, conversion to vector may be time consuming.


5. Resolution
Resolution: Is the total number of pixels that make an image.
6. Dimensional computer graphics
They are mainly used in applications that were originally developed up on traditional printing and drawing technologies.
7. Dimensional computer graphics
Are graphics that use a three dimensional representation of geometric data. This includes images that may be for later display or for real time viewing.
8. Core elements of computer graphics
· Modelling
· Rendering
· Animation
· Interaction
a. Modelling: The process of developing a mathematical representation of any three dimensional surface (3D) of an object via specialized software. the product is called 3D model.
b. Rendering: The process of converting automatically 3D wire frame models into 2D images 3D photorealistic effects or non-photorealistic rendering on a computer.
c. Animation: A process that uses computer generated images to create animated scenes.
d. Interaction: A technique of using a physical input / Output device to perform a board task in human computer dialogue.
6.3. Graphic file format
Graphic images are stored digitally using a small number of standardized graphic file formats such as:
· BMP
· GIF
· JPEG
· TIFF
· PNG
· BMP: Limited file format that is not suitable for use in prepress. It is a file extension for Bitmap file.
· GIF: Graphic Interchange Format mainly used for internet graphics.
· JPEG: Joint Photographic Experts Group which is used for internet graphics, photos, etc.
· JIFF: Tag Image File Format a popular and versatile bitmap file format.
· PNG: Portable Network Graphics.
6.4.  Areas of graphics use
· Entertainment
· Advertisement
· Book illustrations
· Magazines
· Education
· Computing designing computer games, web sites.
a. Entertainment
· Animated pictures
· Audio – videos
· TV shows
· Computer games
b. Advertisement: Primary ways of advertising the sale of goods or service are Graphics.
Example: Creating logos
c. Book illustrations: It is used to produce illustrations which summarize various kinds of data.
Example: To illustrate themes and concepts such as:
· Human anatomy in Biology
· Diagrams in mathematics
d. Magazines: They contain graphic materials in abundance to attract readers.
e. Education: As learning and teaching aid.
6.5.  Graphics software
They are software used to create and to manipulate bitmaps or vector graphics.
· Microsoft Paint
· Adobe Photoshop
· Vector graphics software
1. Microsoft Paint
It allows the user to draw or paint bitmapped images on a computer.
2. Adobe Photoshop
It is used in photography, design and video editing.
3. Vector graphics software
The commonly used are:
· Adobe illustrator
· Adobe FreeHand
· Corel Draw
· Paint shop pro.
Launch Ms Paint program on your computer
· Click the Start button, All Programs
· From Windows accessories, choose Paint.
Note: Canvas: A piece of paper for you to draw or write on.
6.6. Basic graphic elements (With Ms Paint)
· Line and curve tools
· Paint brush tool
· Pencil tool
· Spray can
· Shapes (Circles, ovals, squares, rectangles, …)
· Fill tool
· Ellipse tool
To get a round shape that has a black outline and an orange interior
· Choose the Ellipse tool
· In the Fill options area, choose     then select Solid color.
· Click the Foreground color box, and then click black to set the foreground color.
· Click and hold the left mouse button and drag the mouse to form the oval.
· Use Line tool
· Curve tool
· Fill tool
6.7. Graphic features
· Select tools
· Copy and paste (a selected image)
· To move an image
· To resize an image
· To flip an image
· Add text
· To rotate the image
· To skew an image
· Cut out or trim an image
· To erase something, you have drawn with eraser tool
· Vector graphics
· Manipulate nodes and control point
1. Select tools
Two different tools you can use to select part of your image
· Rectangular selection
· Free from selection
· Rectangular selection (A dotted outline of a rectangle): Lets you draw a rectangle around an image.
· Free from selection (A dotted outline of oval shape): Allows you to draw your own free hand selection line around an image.
Steps to select an image
· Click the arrow beneath the Select button.
· Choose Rectangular or Freeform
· To use either tool selected, start by clicking at the top left corner of your image, then hold down the mouse button as you trace your way around the image. Then release the mouse.
2. Copy and paste (A selected image)
· Select Image and make sure the image is highlighted with dotted rectangle.
· Copy the selected are by pressing CTRL + C or click Copy command from the Home tab.
· Paste the image using CTRL + V or Paste command on the Home tab.
3. To move an image
· Select the image to be moved.
· Click on the selection and drag to a new position.
4. To resize an image
· Select the image
· Click in any of the selection boxes and inwards (To reduce size) or drag outwards (To enlarge its size)
5. To flip an image
· Select the image to be flipped
· In the Image group, click Rotate tool and then select Flip vertical or Flip horizontal.
6. To rotate the image
· Select the Image to be rotated.
· In the Image group, click Rotate tool and then select a Rotate option. (Rotate right 900)
7. To skew an image
· Select an image
· Click Resize tool in the Image group
· In the resize and skew dialog box, use section down for skew and type in Degrees for skewing the image.
8. Cut out or trim an image
· Select a part of the image you want to cut out or trim.
· Press delete key on keyboard
9. Add text
· Select the Text box, which is signified by the letter A.
· Double click somewhere on the canvas to start typing.
· Make sure the text in the text box is exactly the way you want it before switching to another tool.
· Increase the textbox size
· Choose a font face and size from the top of the screen and begin typing.
· Change the color, size or face of the text after you type.
10. To erase something, you have drawn with Eraser tool
· Click the Eraser icon
· Drag over the area you would like to disappear several times until it disappears.
11. Vector graphics
a. To create a vector graphic
· Open Adobe illustrator, a vector graphics software.
· Click on File menu and select New button to get a new document dialog box. Name your file as My shapes.
· Start creating the shapes using various tools.
· Fill the square with green; the circle with gradient fill and rounded rectangle with brown color and increase on its shape outline.
b. To reshape or edit the graphics
· Select the square, click on Effect menu and on the menu click Distort & Transform and then select the Zig zag …effect. 
In the zig zag dialog box, adjust the size to be 12 pts and ridges to be 5. Then click OK. (To reshape or edit the square)
· Select it and on the Effect menu click Texture and then Traquelure.
In the Traquelure dialog box, you can adjust the crack spacing depth and brightness as you like. Click Ok. Select Radial gradient on the right. (To edit circle oval)
· Select it and click Effects menu. On the menu, click Warp and select Shell lower in the Sub menu. (To reshape the rounded rectangle)
Saving a project
· Click on File menu and select Save as. Click Ok.
· the Save dialog box displays. Type in the file name and click on Save button.
12. Manipulate nodes and control points
These are the selection boxes and circles that appear when you select an image for reshaping. Then click and drag inwards or outwards to resize images.
6.8. Graphics formatting
6.8.1. Colors for the outline and fill of objects
· Select a Pencil or a Shape to use 
· Click the Outline button from shapes, select the option you want.
· Click the Desired color
· Drag the mouse to draw the object, then resize the object.
6.8.2. Create shading and fill objects with patterns and textures
· Click on Fill with color tool, then choose the desired color.
· Click Inside the object.
6.9. Edit image
6.9.1. Crop an image
· Click the Select tool at the top of the screen
· Highlight the area you want to crop by clicking and dragging with the cursor.
· Click Crop.
6.9.2. Resize an image
· Click Image, then select Resize
· Type a new size
6.9.3. Rotate an image
· On the tool bar, click Rotate and choose a direction in the menu.
6.9.4. Magnify an area of a picture / zoom
· Click the magnifying glass icon to enable the zoom tool.
· To zoom in, click anywhere on your image with the left mouse button.
· To zoom out, click with the right mouse button.
Or 
Use the keyboard shortcuts:
· CTRL + Pgup: To zoom in
· CTRL + Pgdn: To zoom out
6.9.5. Stretch or skew an image
· Click Image, then select Resize / Skew
· To stretch / distort the image by degree, type number (in degrees) in the boxes marked “Horizontal” and “Vertical” in the Resize and skew dialog box.
6.9.6. Changing Pixels
· Select Pixels
· Uncheck the maintain aspect ratio check box.
· Enter a width (horizontal) and height (vertical) in pixels.
· Click Ok
6.9.7. The color picker
· Click the Color picker tool.
· Click Song where in your drawing. The area you click will now become the foreground color for your next tool of choice.
6.9.8. Change color
· Click Edit colors or Define custom colors to enter the color mixer.
· After you have decided on a color you like, click Add to custom colors.
6.9.9. Brushing tools
Ms Paint has several brushing tools you can use to make your image artistic in appearance.
Brushing tools
· Brush 
· Oil brush
· Water brush
· Crayon
· Marker
· Natural pencil
· Air brush
· Calligraphy brush1
· Calligraphy brush 2
6.9.10. Working with layers in Ms Paint
· Draw an image
· Select your final line art color you want put it in the Color 1 slot, leaving Color 2 slot with White color.
· Put your initial color in Color 1 slot, leaving Color 2 slot White.
· Click on the Eraser button and then Right click while erasing your drawing. This action will remove the original color.
6.9.11. Microsoft Paint 3D
Ms Paint 3D: A new application in Windows 10 creators update, designed for working with 3D graphics. It is a new version of Ms Paint.
Starting Paint 3D
· Click Start
· Type Paint in the search box
· Click on it to open
Note: You still have the opportunity to use both Paint and Paint 3D on your computer. You can use Paint 3D to turn photos into:
· 3D models
· Add colors
· Textures to models you make from 3D
6.10.Using Photoshop
6.10.1. Create a new Photoshop file
· When Photoshop opens, click on File menu and select New
· In the new document screen that appears, select a Category of orientation for your document.
· Type in the file name in the Presets details pane.
· Click Ok at the bottom.
6.10.2. Open an image
· Open or Add an image: In a new file select Open on File menu.
· Select an image you want.
6.10.3. Resize image
· Adjust image size: Use Image menu and adjust image to the size you want.
· Click Image size on the Image menu.
6.10.4. Crop an image
· Select the Crop tool from Image menu or from Tool box.
· Select the part of the picture you want to crop.
· You can press the check button on tool bar.
6.10.5. Use brushing tools
· Remove some rough elements on the image. Use the Spot healing brush and Blur tool.
· After wards apply some light on parts using Dodge tool.
6.10.6. Add text to photo
· Use the Horizontal type tool and draw a Text box in required position.
· Type the text.
6.10.7. Rotate an image
Using the Image menu, on Image rotation menu, select 1800. You can use a different option.
Keyboards shortcuts
	New canvas
	CTRL + N

	Cut
	CTRL + X

	Paste
	CTRL + V

	Copy
	CTRL + C

	Save
	CTRL + S

	Delete
	Del

	Print
	CTRL + P

	Undo
	CTRL + Z

	Highlight All
	CTRL + A

	Open
	CTRL + O

	Redo
	CTRL + Y

	Hide tool bar
	CTRL + T

	Open Attributes
	CTRL + E

	Stretch And Skew
	CTRL + W




UNIT 7: INTRODUCTION TO MULTIMEDIA
7.1. INTRODUCTION
In these days, with the evolution of the use of computers, the demand of multimedia contents has also increased.
Multimedia contents
· Movies
· Power point presentation
· Audio sounds
· Text
· Graphics
· Animation
· Video
7.2. Definition 
Multimedia: Is the collection of medias that use multiple forms of information content and information processing to information or entertain the user.
Multimedia also refers to the use of electronic media to store and experience multimedia content.
Multimedia information can be represented in form of:
· Audio fil
· Graphical file
· Image file
· Video file
· Animation file
7.3. Categories of multimedia
Multimedia may be divided into:
· Linear
· Non – linear
a. Linear multimedia: Active content progresses without any navigation control for the viewer / user.
Examples: 
· Movies
· Video clips
· Songs
b. Non – linear multimedia: Content offers the ability to control the content interactivity with the user / viewer.
Examples:
· Computer games
· Assimilation software
Multimedia presentations
· Live
· Recorded
1. A live multimedia presentation: Occurs when things are happening at that moment.
Examples:
· News on television
· Football game
2. A recorded presentation: A presentation which has been recorded and edited, after all processing stages.
Example:
· TV program
Features of multimedia
· Presentations may be viewed in person on stage, projected, transmitted, and played locally with a media player.
Examples:
· Power point presentation
· Cinema presentation
· Games and simulations may be used in a physical environment with special effects, played / used by multiple users on the computer network and locally with an offline compute, game system, simulator.
Examples:
· Online game
· Game on mobile telephone
7.5. Types of multimedia
· Text
· Graphics
· Animation
· Audio
· Video
a. Text: It is used to inform users about the information that it wishes to communicate.
b. Graphics: It uses pictures as visuals in digital form used in multimedia presentations.
Two types of graphics
· Bitmap graphics (Image raster)
· Vector graphics
1. Bitmap graphics: Formed by Pixels arranged in specific ways in a matrix form.
2. Vector graphics: Formed by lines that follow mathematical equations called Vector.
c. Animation: The process of adding movements to static images or picture through using various computing methods.
d. Audio: The sound in digital form used in multimedia presentations.
e. Video: Moving pictures in digital form in multimedia presentations.
7.6. Applications of multimedia
The applications of multimedia are found in various areas including:
· Commercial
· Entertainment
· Education
· Industry
· Industry
· Medicine
· Multimedia in public places (Airport)
· Advertisements
· Art
· Engineering
· Mathematics
· Business
· Scientific research
7.7. Hardware and software in the multimedia requirement
7.7.1. Multimedia hardware
· Computer
· Digital camera
· Microphone
· Scanner
· Speaker
· Headphone
· TV screen
· CD / DVD
7.7.2. Multimedia software
	Software
	Description

	Adobe Acrobat pro
	Protect documents


	Adobe creative suite master collection
	Supporting applications


	Facetime
	Make video calls


	Final cut studio pro
	Video editing


	Hand Brake
	Video encoder


	iCal
	Personal calendar application


	Image capture
	Upload pictures from digital cameras or scanners

	iTunes
	Download media for Mac, PC, iPad, and iPhone

	Microsoft office suite
	Excel, power point, word and Access


	Photo Booth 
	Take photos and videos with an iSight camera



7.8. Interactive multimedia
7.8.1. Create hyperlinks to link to a slide in the current presentation
· In Normal view, select the text, shape, or picture that you want to use as hyperlink.
· On the Insert tab, in the Links group, click Hyperlink.
· In the Insert hyperlink dialog box, under Link to, click Place in this document.
· Select First slide, Next slide, Previous slide or Last slide.
· Click Ok.
7.8.2. Create hyperlinks to link to a slide in a different presentation
· In Normal view, select text, shape, or picture that you want to use as a hyperlink.
· On the Insert tab, in the Links group, click Hyperlink.
· Under Link to, click Existing file or web page.
· Locate and select the presentation file that contains the slide that you want to link to.
· Click Book mark and then click the title of the slide that you want to link to.
· Click Ok and then Ok.
7.8.3. Create hyperlinks to link to an e-mail address
· In Normal view, select the text, shape, or picture
· On the Insert tab, in the Links group, click Hyperlink.
· Under Link to, click E-mail box, type the e-mail address that you want to link to, or in the Recently used e-mail addresses box, click an e-mail address.
· In the Subject box, type the subject of the –mail message.
7.8.4. Create hyperlinks to link to a new file
· In Normal view, select text, shape, or picture.
· On the Insert tab, in the Links group, click Hyperlink.
· Under Link to, click Create new document.
· In the Name of new document box, type the name of the file that you want to create and link to.
· Under When to edit, click whether you want to Edit the new document later or Edit the new document now.
7.9. Create action buttons
7.9.1. Add commands to your Presentation with action buttons
· On the Insert tab, in the Illustrations group, click Shapes, and then under Action buttons, click the button shape that you want to add.
· Click a location on the slide, and then drag to draw the shape for the button.
· In the Action settings dialog box, do one of the following:
· To choose the behavior of the action button where you click it in slide show view, click the Mouse click tab.
· To choose the behavior of the action button when you move the pointer over it in slide show view, click the Mouse over tab.
· To choose the action that will take place when you click or move the pointer over the action button, do one of the following:
· To play a sound, select the Play sound check box, and then select the sound that you want to play.
· Click Ok.
7.9.2. Insert an MP3 audio file into a presentation
· From the Insert tab, click the Audio dropdown arrow, and then select Audio on My PC.
· Locate and select the desired audio file, then click Insert.
· The audio file will be added to the slide.
7.9.3. Insert a video file into a presentation
· From the Insert tab, click the Video drop down arrow, and then select Video on My PC.
· Locate and select the desired audio file, then click Insert.
7.9.4. Insert a CD audio track in the presentation
· Click the File tab, and then click Options in the navigation pane.
· In the navigation pane of the Power point options window, click Customize Ribbon.
· In the Customize ribbon column, in the Main tabs list, expand Insert, and then select Media.
· Under the Main tabs list, click New group. The new group named New group (Custom) is inserted under the Media group.
· Click Rename, style CD audio, and then click Ok.
· In the Choose commands from drop down list, select All commands.
· Locate and then select the Play CD Audio Track command, and then click the Add button. The command appears under the new CD Audio group.
· Click Ok.
· Return to Insert tab and click Play CD Audio track from CD Audio group (New group created). This will work as long as you have the CD inserted in computer.
7.10. Create digital image, audio and video file
· Open and switch on digital camera.
· Click the video capture button
7.10.1. manipulate an image
Saving an image
· Right click on the image, follow the steps below:
· Choose File
· Select either Save or Save as. 
· The Save image window opens.
Create a new image
· Choose File, New
· Enter the image size, image type, and fill type of the file.
· Click the Ok button. Edit and manipulate the image with the GIMP’s various tools.
· Save your file
Note: GIMP: GNU Image Manipulation Program
Editing an image
· Open the image
· Browse your picture from the computer.
· Right click on the image and select Tools – Transform tools – Crop
· Left click and rag the mouse pointer to create a frame that fits the part of the image to keep.
· Click the Crop button
· If you are unhappy with the cropped image, press CTRL + Z
To rotate an image
· Open the image
· Right click on the image and select Image – Transform, then select any of the Fip or Rotate options.
· If you are unhappy with the changes, press CTRL + Z.

Method 1: To Create / record video (In Power point)
· Create a power point presentation and save it.
· Add transitions and animations to your power point presentation.
· Add audio to your presentation. On Insert tab, in the Media group, click Audio. On the Audio menu, select Audio on My PC.
· Record narration and add timings to the slide show Record a narration during a presentation.
· In Normal view, select the slide that you want to start the recording on.
· On the Slide show tab, in the Set up group, click Record slide show.
· In the Record slide show box that displays, click Start recording.
· Export (Save) your power point presentation as a video by:
· Click File tab, select Export and then click Create video. On the Recording tab of the ribbon, click on Export to video.
· Click Create a video
Method 2: To create video (Move) file using Windows Move Maker
· Start Windows Move maker
· On the Home tab, in the Add group, select Add videos and photos.
· In the videos and photos dialog box, open the folder that contains the photos or videos that you want to add, select the video files and photos, and then select Open.
Add and edit audio in Movie maker
To add music
· On the Home tab, in the Add group, select Add music.
· Select the music file you want to use and then select Open.
To fade music in or out
· Select the music you want to fade in and or out.
· Under Music tools, in the Options tab, in the Audio group, do either and or:
· Select the Fade in list, and then select the speed for the music to fade in.
· Select the Fade out list, and then select the speed for the music to fade out.
To change the start or end point of the music
· Select the music
· Drag the Play back indicator on the story board to the point in the music where you want it to start or stop playing in your movie.
Do the following:
· To set a new start point for the music to start playing at the current point, under Music tools, on the Options tab, in the Editing group, select Set start point.
· To set a new end point so the music stops playing at the current point, under Music tools, on the Options tab, in the Editing group, select Set end point.
To change the audio volume of a music item
· Select the music
· Under Music tools, on the Options tab, in the Audio group, select Music volume and then move the slider left to lower the volume or right increase it.
To trim a video in Movie maker
· On the Home tab, in the Add group, select Add videos and photos.
· In the Add videos and photos dialog box, open the folder that contains the photos or videos you want to add, select the video file or photo, and then select Open.
· Select the Video that you want to trim.
· Under Video tools, on the Edit tab, in the Editing group, click on Trim tool, either and or.
· Move the slider under neath the preview monitor to the point that you want the video to start, and then select Set start point.
· Move the slider under neath the preview monitor to the point that you want the video to stop playing, and then select Set end point.
Split a video
To split a video into two items
· Select your video, and drag the play back indicator to the point where you want to split the video.
· Under Videos tools, on the Edit tab, in the Editing group, select Split.
Speed up or slow a video
· Selecting the video, and under Video tools, on the Edit tab, in the Adjust group, select the Speed list, and then select a Speed that you want.















UNIT 8: NETWORK SECURITY
8.1. Introduction 
Network security: Consists of policies implemented to prevent and monitor unauthorized access, modification or denial of a computer network and network accessible resources.
8.2. Definition of terms
· Security: Something that provides a sense of protection against attack, harm or loss.
· Computer security: Techniques developed to safeguard information stored on computer network.
· Threat: A possible danger that might exploit a vulnerability to break security and can cause damage, pain and loss.
· Vulnerability: A weakness in a system which allows an attacker to reduce system’s in formation assurance.
· Authentication: A process used to identify individuals based on username and password.
· Authorization: A permission to perform action.
· Encryption: The process of encoding messages between two or more parties information such that hackers cannot read the message/ information except the authorized parties.
Importance of encryption
· It protects data in transit. (i.e: Internet, ATM, Mobile phone, Wireless microphone, blue tooth devices, E-commerce)
· It is used to protect information on computers and storage devices such as flash drives.
· It is used by governments and in the military to facilitate secret communication.
· Decryption: The process of decoding messages information such that authorized parties can read them.
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Firewall: Security software designed for preventing / blocking unauthorized access to data      and system software on a computer network.
8.3. Importance of computer security
· Protect the computer
· Protect data
· Protect user’s identification
Purpose of computer security
· Keep your information on computer protected 
· Maintain your computer’s overall health.
· Help prevent viruses and malware.
· Help programs run more smoothly.
8.4. Security threats
Security threat: Anything that has the potential to cause serious harm to a computer system.
8.4.1. Origins of threats
· Deliberate (Illegal processing of data)
· Accidental (Failure of equipment and software)
· Negligence
· Environmental (Loss of power, natural event)
8.4.2. Threats categories
· Intended threats: People within the organization. This is the most dangerous threat.
· External threats: People outside the organization such as thieves, hackers.
The treats in general that commonly affect systems
· Physical damage
· Natural disasters
· Loss of essential services
· Compromise of information
· Technical failure
8.4.3. Computer networks attacks
· Computer viruses 
· Spyware
· Trojan horse
· Social engineering 
· Identity theft
· Sabotage by employees
· Denial of services attack (DoSA)

To make a file a Read – Only
· Open the folder where you often save your files such as My documents folders.
· Right click on a file (s) and in the shortcut menu select “Properties”
· In the File properties dialog box that displays, check read – Only attribute.
· Click Apply
To hid a file
· Open a folder where your files are stored.
· Right click on a file and select Properties.
· In the File properties dialog box that displays, check Hidden attribute. 
· Click on Apply
To encrypt a file or folder
· Open a folder where your files are stored.
· Right click on the file and select properties.
· In the File properties dialog box that displays, click Advanced attribute.
· In the Advanced attribute dialog box that displays, check box for “Encrypt contents to secure data” and then click “OK”
·  Click on Apply.
To unhide hidden file (s)
· Open Control panel window and display the contents as small or large icons.
· Click on File Explorer options
· In the File explorer options dialog box displays, click on View tab.
· Select “Show hidden file, folders and drives”
8.5. Security procedures
8.5.1. Protect physical equipment
· To protect physical equipment against fire, put in place fire extinguishers, use metallic doors and windows with strong padlocks. Use security cameras, alarms and security guards.
· Use UPS (Uninterruptible Power Supply) to protect system failure and data loss.
· Use power surge protector to protect your computer against voltage spikes that can harm your system.
8.5.2: Protect data
Protection of data: Is aimed at safe guarding data against loss, damage and theft.
The procedures
· Data backups
· Regularly update antivirus software.
· Scan your computer.
· Update your operation system regularly.
· Have a strong password and change it frequently.
· Install and configure a firewall.
· Don’t download information from the insecure websites
· Don’t open e-mail attachments from unknown sources.
· Scan every external disk memory attached to your computer to protect from malware.
· Scan all shareware and freeware before installing them on your computer.
To be sure and secure, that your data is protected, do the following:
· Create a duplicate copy of your critical data.
· Backup critical and essential files on a daily basis.
· Backup non-critical files on a weekly or monthly basis.
· Store your backup media (CD, DVD)
· Periodically, test the capability to restore from the backup media.
8.6. Basic security precautions
Security precautions: Guidelines you need to follow in order to use a system when you are protected on a network. You need these guidelines on both Wireless and Wired network.
8.6.1. Wireless networks
Techniques used to protect wireless networks
· Control access rights
· Don’t expose your SSID sever password for your wireless network or login password to wired network.
· Encrypt your Wi – Fi network. Use encryption method.
· Disconnect your PC from the network when you are not using it.
· Enable firewall and the antivirus software on each computer.
8.6.2: Wired networks
Techniques used to protect wired network
· Control direct physical access to network devices and avoid unauthorized access.
· Use strong passwords that must be regularly changed.
· Disconnect your PC from the network when it is not in use.
· Use hardware firewall for access to external network and internet.
· Secure loose cables.









UNIT 9: PLATFORM GAME PROGRAMMING
9.1. Concepts of platform and its usage
A platform sprite: A immobile sprite usually a stage background and can interact with other sprites on stage. It is the avatar controlled by the player.
Avatar: A picture representing a particular person or something in a game.
9.1.1. Create platform sprites
Before you create a platform sprite, you must know:
· What type of the game you want the platform to work for?
· The level of the game, etc.
9.1.2. Interact with platform sprites
Two or more sprites may interact with each other when they touch each other, or touches certain specified colors, moves in certain direction, etc.
9.1.3. Role of platforms in Scratch
The platform acts as an area of sprite interactions.
9.2. Creating a platform sprite
9.2.1. Pick a color
Scratch editor has very many colors to choose from.
9.2.2. Design a needed item
Use Scratch Paint tools to design a needed item. (Platform)
9.2.3. To edit or copy a sprite or an item
To edit a backdrop: Click on it and type a new name.
To copy a backdrop: Right click on it and select Duplicate.
To delete a backdrop: Right click on it and select Delete.
To edit a sprite name: Click on default name and type the new name.
To copy a sprit: Right click on the sprite, select Duplicate.
To delete a sprite: Right click on the sprite, select Delete.
9.2.4. Build a combo block
A combo block: A combination of scripts that can make a sprite to move, jump, walk, make sound, etc.
Steps to create backdrop 2
· Select Stage 1 backdrop and then click on the Backdrops tab.
· Right click on Terrain 1 backdrop and select Duplicate. This will create Terrain 2 backdrop.
· Make changes to the backdrop using Scratch Paint tools to appear.
9.3. Add level of a game
You can use colors in a platform to detect the end of a level or determine the end using edge of a platform. You can also an object which sends one back to the beginning of the level.
Steps for making a variable
· On the Scripts tab, click Data block.
· Click Make a variable. In the New variable dialog box, type in Jumb (or other variable)
· Select For this sprite only and click Ok.
9.4. Command for sprite manipulation
· Color () is touching ()?
· Repeat until
· Change () by ()
· Key () Pressed?
· Touching ()?
· Touching color ()?
· Switch costume to ()
· [bookmark: _GoBack]Switch backdrop to (ss) 
· Switch backdrop to () and wait
· Next costume
· Next backdrop
9.5. Sample controls
· Repeat ()
· Forever
· If () then
· If () then, else
· Move () steps
· Turn () degrees (clockwise)
· Turn () degrees (counter clockwise)
· Point towards ()
· Point in direction ()
· Go to X: () Y: ()
· Go to ()
· Touching ()?
· Show
· Hide
· Set () to ()
· Change () by ()
· Show variable ()
· Hide variable ()

